Feeds

Actualités informatiques

DSA-4380 golang-1.8

Debian Security Advisory

DSA-4380-1 golang-1.8 -- security update

Date Reported:
01 Feb 2019
Affected Packages:
golang-1.8
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2018-6574, CVE-2018-7187, CVE-2019-6486.
More information:

A vulnerability was discovered in the implementation of the P-521 and P-384 elliptic curves, which could result in denial of service and in some cases key recovery.

In addition this update fixes two vulnerabilities in go get, which could result in the execution of arbitrary shell commands.

For the stable distribution (stretch), these problems have been fixed in version 1.8.1-1+deb9u1.

We recommend that you upgrade your golang-1.8 packages.

For the detailed security status of golang-1.8 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/golang-1.8