Feeds

Actualités informatiques

DSA-4424 pdns

Debian Security Advisory

DSA-4424-1 pdns -- security update

Date Reported:
04 Apr 2019
Affected Packages:
pdns
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 924966.
In Mitre's CVE dictionary: CVE-2019-3871.
More information:

Adam Dobrawy, Frederico Silva and Gregory Brzeski from HyperOne.com discovered that pdns, an authoritative DNS server, did not properly validate user-supplied data when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend. This would allow a remote user to cause either a denial-of-service, or information disclosure.

For the stable distribution (stretch), this problem has been fixed in version 4.0.3-1+deb9u4.

We recommend that you upgrade your pdns packages.

For the detailed security status of pdns please refer to its security tracker page at: https://security-tracker.debian.org/tracker/pdns