Feeds

Actualités informatiques

DSA-4488 exim4

Debian Security Advisory

DSA-4488-1 exim4 -- security update

Date Reported:
25 Jul 2019
Affected Packages:
exim4
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2019-13917.
More information:

Jeremy Harris discovered that Exim, a mail transport agent, does not properly handle the ${sort } expansion. This flaw can be exploited by a remote attacker to execute programs with root privileges in non-default (and unusual) configurations where ${sort } expansion is used for items that can be controlled by an attacker.

For the oldstable distribution (stretch), this problem has been fixed in version 4.89-2+deb9u5.

For the stable distribution (buster), this problem has been fixed in version 4.92-8+deb10u1.

We recommend that you upgrade your exim4 packages.