Feeds

Actualités informatiques

DSA-4541 libapreq2

Debian Security Advisory

DSA-4541-1 libapreq2 -- security update

Date Reported:
04 Oct 2019
Affected Packages:
libapreq2
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 939937.
In Mitre's CVE dictionary: CVE-2019-12412.
More information:

Max Kellermann reported a NULL pointer dereference flaw in libapreq2, a generic Apache request library, allowing a remote attacker to cause a denial of service against an application using the library (application crash) if an invalid nested multipart body is processed.

For the oldstable distribution (stretch), this problem has been fixed in version 2.13-7~deb9u1.

For the stable distribution (buster), this problem has been fixed in version 2.13-7~deb10u1.

We recommend that you upgrade your libapreq2 packages.

For the detailed security status of libapreq2 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libapreq2