Feeds

Actualités informatiques

DSA-4613 libidn2

Debian Security Advisory

DSA-4613-1 libidn2 -- security update

Date Reported:
01 Feb 2020
Affected Packages:
libidn2
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 942895.
In Mitre's CVE dictionary: CVE-2019-18224.
More information:

A heap-based buffer overflow vulnerability was discovered in the idn2_to_ascii_4i() function in libidn2, the GNU library for Internationalized Domain Names (IDNs), which could result in denial of service, or the execution of arbitrary code when processing a long domain string.

For the stable distribution (buster), this problem has been fixed in version 2.0.5-1+deb10u1.

We recommend that you upgrade your libidn2 packages.

For the detailed security status of libidn2 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libidn2